[getdns-api] Rename dnssec_return_supporting_responses

Willem Toorop willem at nlnetlabs.nl
Fri Jan 24 04:23:14 MST 2014

How about renaming the "additional_dnssec" attribute (returned when
dnssec_return_validation_chain extension is set) in "validation_chain"?

op 21-11-13 03:45, Paul Hoffman schreef:
> On Nov 20, 2013, at 1:35 PM, Willem Toorop <Willem at NLnetLabs.nl> wrote:
>> The name dnssec_return_supporting_responses is a bit confusing because
>> the word "responses" seem to refer to actual response packets.  I
>> propose to rename this to dnssec_return_validation_chain.  The
>> "additional_dnssec" in the response dict should contain all the resource
>> record dicts for all the resource records (DS, DNSKEY and their RRSIGs)
>> that are needed to perform the validation from the root up.  The
>> resource record dicts should be in the same format as resource records
>> in the packet sections of replies in the "replies_tree" section of a
>> response dict.
>> What do you think?
> Both seem good to me.
> --Paul Hoffman
> _______________________________________________
> getdns-api mailing list
> getdns-api at vpnc.org

More information about the getdns-api mailing list