[getdns-api] Rename dnssec_return_supporting_responses

Paul Hoffman paul.hoffman at vpnc.org
Wed Nov 20 19:45:50 MST 2013

On Nov 20, 2013, at 1:35 PM, Willem Toorop <Willem at NLnetLabs.nl> wrote:

> The name dnssec_return_supporting_responses is a bit confusing because
> the word "responses" seem to refer to actual response packets.  I
> propose to rename this to dnssec_return_validation_chain.  The
> "additional_dnssec" in the response dict should contain all the resource
> record dicts for all the resource records (DS, DNSKEY and their RRSIGs)
> that are needed to perform the validation from the root up.  The
> resource record dicts should be in the same format as resource records
> in the packet sections of replies in the "replies_tree" section of a
> response dict.
> What do you think?

Both seem good to me.

--Paul Hoffman

More information about the getdns-api mailing list